Hello there! Welcome to Youjoomla Support Forums

We are Web Development Company specializing in Joomla Templates , Joomla Extensions and WordPress Themes development . You are not able to see some forum threads due to your memberhip level. To unlock all forums and special customer support please take few moments to signup . If you are just searching for free joomla templates , or free joomla extension support simply head to our Free Joomla Support forums and open a new thread. Our moderators will help you as soon as possible. To spead up the response time please take few seconds and go over forum rules

Have fun!

YJSG 2.0 and K2 item edit not able to add tags

09-15-2014, 03:56 PM
# 1 (permalink)

Hi Neo
Sadly i discovered another problem. The K2-component is not working quite properly after the update. I had to put back my backup on the live-site.
On my test-site (i sent you the cred's) i installed also the backup with the old template. I uninstalled the bug you mentioned and updated to yjsg 2.0. It seems to work fine but when i want to create an article in K2 from the frontend, i cannot select TAGs anymore. Also, when i save a created article, the frontpage of the site appears in the K2 popup-window. I'll pm you an author-login so you can test.
I hope you can help me.
09-15-2014, 04:49 PM
# 2 (permalink)
ok it is a bug , you would need to manually change it in plugins/system/yjsg/yjsg.php

find and change 2 instances of

PHP Code:

if ($k2check){ 


PHP Code:

if ($k2check && $this->Input('task') !='edit'){ 
I added this to 2.0.1 which should be out in few days
09-16-2014, 05:25 PM
# 4 (permalink)

I changed the code exactly as you describe but it doesn't solve the problem...
09-17-2014, 05:26 AM
# 6 (permalink)

Hi Neo
When i create a new article it is not working but when i reopen and edit a just created article it works... Also editing your created article tags can be added.
I tried on a different computer with same result.
09-17-2014, 05:32 AM
# 7 (permalink)

in the author account you see the examples
09-17-2014, 06:13 AM
# 8 (permalink)
change the new line to

PHP Code:

if ($k2check && ($this->Input('task') !='edit' || $this->Input('task') !='add')){ 
09-17-2014, 01:20 PM
# 9 (permalink)

i tried in firefox and chrome and it is not solved here with this code... Same error but now the edit of articles also.
09-17-2014, 02:39 PM
# 10 (permalink)
sorry about that I did not test it

this one works

PHP Code:

if ($k2check && $this->Input('tmpl') !='component'){ 
Thread Tools
Display Modes

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

Members Login