Hello there! Welcome to Youjoomla Support Forums

We are Web Development Company specializing in Joomla Templates , Joomla Extensions and WordPress Themes development . You are not able to see some forum threads due to your memberhip level. To unlock all forums and special customer support please take few moments to signup . If you are just searching for free joomla templates , or free joomla extension support simply head to our Free Joomla Support forums and open a new thread. Our moderators will help you as soon as possible. To spead up the response time please take few seconds and go over forum rules

Have fun!

Template missing jdoc statements:?

01-28-2021, 06:05 PM
# 1 (permalink)
thomaslab
Hi,
Having problems with RSEvents!PRO functionallity and after Their investigation they found this:

Message: Hello,

After a closer investigation we've noticed that what you're encountering seems to be an issue with your template not loading assets or missing this tag:

<jdoc:include type="message" />

Please directly contact your template developers on this matter as your template is probably missing specific jdoc statements:

https://docs.joomla.org/Jdoc_statements
Regards!

****I responded ***
I can se in /templates/system/component.php that this is present, so why doesn't it load?
<body class="contentpane">
<jdoc:include type="message" />
<jdoc:include type="component" />
</body>

***** I got this reply from RSJoomla **********
Hello,

It appears that this is overwritten by your template, from what I can see in the source code, you have:

<!-- messages -->
<div class="yjsg-system-msg">

</div>
<!-- end messages -->

...while Joomla! searches for:

<div id="system-message-container">

I would recommend contacting your template developers directly, unfortunately we're not providing debug services for third party integrations.

Regards!

*******UPDATE**************
Update: I can see yjsg version 2.2.3 moved the location of the doc library:
"* Adapt to Joomla 3.5.0 JDocumentHTML class folder libraries/joomla/document/html changed to libraries/joomla/document"
But in Joomla 3.9.x this folder doesn't exist. It was last seen in Joomla 3.7.5,

************Addition **********
I have the same problem at my official site:
https://www.rojteatern.nu/kommande-e...ver-twist.html
If I'm logged in as a frontend admin I see some layout issues and I can't submit any updates in RSEvents!PRO.

I've also had the issue posted at the Joomla forum:
https://forum.joomla.org/viewtopic.php?f=713&t=984443
and cleared some unrelated isses from the installation.

************* Any thoughts? ***********

Update: reading the "/plugins/system/yjsg/yjsg.php" it seems as if it is not including Joomla 3.9.x in the parsing.


Are you sure your are posting in product assigned forum?: Yes

What is your CMS version?: Joomla 3.x

MySQL Version: 5.x

PHP version: 5.x

Link to installation: https://www.biljett.rojteatern.nu/ko...ver-twist.html

Have you edited any files? If yes tell us which ones.: No

Is this personal or client website?: Personal
Thread Tools
Display Modes

Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

Members Login

Username
Password