Hello there! Welcome to Youjoomla Support Forums

We are Web Development Company specializing in Joomla Templates , Joomla Extensions and WordPress Themes development . You are not able to see some forum threads due to your memberhip level. To unlock all forums and special customer support please take few moments to signup . If you are just searching for free joomla templates , or free joomla extension support simply head to our Free Joomla Support forums and open a new thread. Our moderators will help you as soon as possible. To spead up the response time please take few seconds and go over forum rules

Have fun!

Joomla 2.5.1 get_called_class() fix

12-24-2011, 02:47 PM
# 1 (permalink)
Dear members we a very proud to announce that our templates and extensions run smoothly on joomla 2.5.1 beta.

We are still in testing phase for all possible server versions and 1 issue that is an actual joomla 2.5 requirement could give you some headache. PHP 5.3.

There is new php class introduced in php 5.3 version called


Everyone who is not able to upgrade their php version from PHP 5.2.x to PHP 5.3.x will have trouble with default Joomla 2.5.x and up.

You will see an error saying


Fatal error: Call to undefined function get_called_class() in your_joomla/libraries/joomla/form/field.php on line 203
or something similar

Do not be alarmed , if you are using our templates or our extensions this error might be visible only in admin backend when you try to go in extensions/template settings , quick fix for this is available. Please download the file attached , extract the zip and add file name yjsgclassfix.php in :

template-or-extensions/elements folder

example: Yougrids template


example: YJME module engine


Now go to that elements folder and open any custom elements you see there.

Which are usually solo php files and are in elements folder not in elements/sub_folder if one is available.

example: Yougrids template


example: YJME module engine


Right after


defined('JPATH_BASE') or die();


all set.
Attached Files
File Type: zip yjsgclassfix.zip (804 Bytes, 18 views)
12-31-2011, 04:10 PM
# 2 (permalink)

I have gone into /httpdocs/templates/yougrids/elements/ and added the downloaded file.

Then i have gone to /httpdocs/templates/yougrids/elements/ and edited httpdocs/templates/yougrids/elements/yjsglist.php and added the include_once('yjsgclassfix.php');

This is for YouGrids, is that it, as it is still the same problem.
01-06-2012, 04:19 PM
# 3 (permalink)
I have still not got the menu working. Are the YouGrids templates updated for this error? Can the YouGrids package be downloaded and uploaded via FTP to fix the error on different template pages?
01-06-2012, 06:43 PM
# 5 (permalink)
I did everything as described but still not working and shows up as shown here.
Attached Thumbnails
01-07-2012, 06:10 PM
# 7 (permalink)
That fixed the problem. Many thanks.
01-15-2012, 10:44 AM
# 8 (permalink)
Added include_once('yjsgclassfix.php'); to each file present il elements directory work fine in 2.5 beta 2.

Even works with template additions and customisation as i tried before and succeeded with Youjoomla help on 1.7.2 : http://www.youjoomla.com/joomla_supp...wont-work.html

Thank you.
01-19-2012, 11:06 PM
# 9 (permalink)
after further digging here is the full fix for the above problem , there is no need to add the function , just download the set of 2.5 template compatible elements and extract it in

templates/template_name/elements folder overriding the existing ones

for YJ Mega Menu Plugin 1.6 and UP just download the plugin

and reinstall
Attached Files
File Type: zip elements_25_comp.zip (9.1 KB, 2 views)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Powered by vBulletin®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.

Members Login