Youjoomla Support Forums (
-   YouGrids (
-   -   Front end editing has disappeared (

NickC4555 05-28-2013 08:34 AM

Front end editing has disappeared
Since upgrading to YJSG Version 1.0.14 front end editing has disappeared - the icon is no longer displayed. Switching to any other template fixes it.

Are you sure your are posting in product assigned forum?: Yes

What is your CMS version?: Joomla 2.5

MySQL Version: 5.x

PHP version: 5.x

Link to installation:

Have you edited any files? If yes tell us which ones.: No

Is this personal or client website?: Client

orion_ 05-28-2013 03:25 PM

Your site is locked..can you provide a screenshot please

NickC4555 05-29-2013 10:25 AM

I pm'd you the login.

orion_ 05-29-2013 06:41 PM

Thank you

I don't know if you have changed anything from the defaults, but I have used this template with front-end editing without any trouble.

I noticed that you have a lot of updates for extensions, wonder if you need to update JCE or dig through the JCE editing settings..

Isn't this what you are after.. (the pencil and paper icon)?
Screenshot by Lightshot

NickC4555 05-30-2013 06:59 AM

Yes, that's what is missing. It was there before the YJSG 1.0.14 upgrade, with exactly the same extensions.

neo 05-31-2013 06:02 AM

it is there but diff icon now , give me few min

neo 05-31-2013 06:05 AM

here it is
Screenshot by Lightshot

try switching browser, the icons by default are now font icons , you browser "might" have an issue displaying it

NickC4555 06-04-2013 05:25 AM

I tried Chrome and IE, no icon visible on my customer's site. Could it be a jQuery issue?

neo 06-04-2013 05:29 AM

well , no JS has nothing to do with it , what it could be is permission.
but we would need admin access in order to test

neo 06-04-2013 06:14 AM

I see the icons
Screenshot by Lightshot

neo 06-04-2013 06:15 AM

Screenshot by Lightshot

Screenshot by Lightshot

neo 06-04-2013 06:17 AM

I think i see what you mean , you are talking about the edit within the article itself
Screenshot by Lightshot

looks like I missed it on update , will add in 1.0.15 in few min i'l give you the code you need

neo 06-04-2013 06:33 AM

it has something to do with permissions

I am checking on my local first

well seems like I did not miss it ,

JBootstrap plugin on
Screenshot by Lightshot

JBootstrap off

Screenshot by Lightshot


checks if you can edit article , if yes the icon will be displayed. few more min

neo 06-04-2013 07:08 AM

ok found the issue ,


line 37 starts with

PHP Code:

$newsitemTools = (($params->get('show_author')) or 

change to

PHP Code:

$newsitemTools = ($canEdit or ($params->get('show_author')) or 

Screenshot by Lightshot

will be added in YJSG 1.0.15

NickC4555 06-05-2013 05:04 AM

That fixed it, thank you.

All times are GMT -4. The time now is 05:09 PM.

Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.