Youjoomla Support Forums (https://www.youjoomla.com/joomla_support/index.php)
-   YJSG Template Framework Plugin (https://www.youjoomla.com/joomla_support/forumdisplay.php?f=269)
-   -   Template missing jdoc statements:? (https://www.youjoomla.com/joomla_support/showthread.php?t=16406)

thomaslab 01-28-2021 05:05 PM

Template missing jdoc statements:? Joomla 3.9.x-ready?
 
Hi,
Having problems with RSEvents!PRO functionallity and after Their investigation they found this:

Message: Hello,

After a closer investigation we've noticed that what you're encountering seems to be an issue with your template not loading assets or missing this tag:

<jdoc:include type="message" />

Please directly contact your template developers on this matter as your template is probably missing specific jdoc statements:

https://docs.joomla.org/Jdoc_statements
Regards!

****I responded ***
I can se in /templates/system/component.php that this is present, so why doesn't it load?
<body class="contentpane">
<jdoc:include type="message" />
<jdoc:include type="component" />
</body>

***** I got this reply from RSJoomla **********
Hello,

It appears that this is overwritten by your template, from what I can see in the source code, you have:

<!-- messages -->
<div class="yjsg-system-msg">

</div>
<!-- end messages -->

...while Joomla! searches for:

<div id="system-message-container">

I would recommend contacting your template developers directly, unfortunately we're not providing debug services for third party integrations.

Regards!

*******UPDATE**************
Update: I can see yjsg version 2.2.3 moved the location of the doc library:
"* Adapt to Joomla 3.5.0 JDocumentHTML class folder libraries/joomla/document/html changed to libraries/joomla/document"
But in Joomla 3.9.x this folder doesn't exist. It was last seen in Joomla 3.7.5,

************Addition **********
I have the same problem at my official site:
https://www.rojteatern.nu/kommande-e...ver-twist.html
If I'm logged in as a frontend admin I see some layout issues and I can't submit any updates in RSEvents!PRO.

I've also had the issue posted at the Joomla forum:
https://forum.joomla.org/viewtopic.php?f=713&t=984443
and cleared some unrelated isses from the installation.

************* Any thoughts? ***********
Update:
From RSEvents!PRO:
What you're experiencing isn't caused by RSEvents!Pro, from what I can see in the console, a JavaScript error is returned:

1/ Uncaught TypeError: t.fn.tooltip is undefined
2/ Uncaught TypeError: messageContainer is null
removeMessages https://www.rojteatern.nu/media/syst...61ea4da099a6:1
validate https://www.rojteatern.nu/media/com_...s/edit.js:1568
save https://www.rojteatern.nu/media/com_...s/edit.js:1579
init https://www.rojteatern.nu/media/com_...js/edit.js:173
jQuery 2
dispatch
handle


Are you sure your are posting in product assigned forum?: Yes

What is your CMS version?: Joomla 3.x

MySQL Version: 5.x

PHP version: 5.x

Link to installation: https://www.biljett.rojteatern.nu/ko...ver-twist.html

Have you edited any files? If yes tell us which ones.: No

Is this personal or client website?: Personal


All times are GMT -4. The time now is 10:36 AM.

Powered by vBulletin®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.