Youjoomla Support Forums (
-   JCompress (
-   -   [SOLVED] Can't see any change ... how do I know it's working? (

ckubse 01-28-2015 12:27 PM

[SOLVED] Can't see any change ... how do I know it's working?
A week or so ago I was on Youjoomla site, liked what I saw and decided to switch T3 I used with Eximium.
Normally I saw the blog post about Jcompress and decided to use that too. Unfortunatelly I can't tell if it's working or not. Someone can help me:
- Do I have to integrate it somehow with the theme framework, or it doesn't matter?
- On my site I have also enabled expire headers. Could be those the source of my problem? I found directives in htaccess for JS and CSS to expire after one week.

Are you sure your are posting in product assigned forum?: Yes

What is your CMS version?: Joomla 3.x

MySQL Version: 5.x

PHP version: 5.x

Link to installation:

Have you edited any files? If yes tell us which ones.: No

Is this personal or client website?: Personal

neo 01-28-2015 12:46 PM

so far I see the plugin is not active on your site.
Did you install and published the plugin ?

ckubse 01-28-2015 01:56 PM

Yes it's active. The cache time is the default 24h.
Now I see that for example on this page( never visited it in the last few says or so) It's working because I see the minified CSS and JS.
On homepage and some pages I visited more often in the last days it doesn't. :( I thought it could have something to do with expire headers i have in htaccess. :(

neo 01-28-2015 04:33 PM

htaccess should not affect it. the jcompress plugin order should be very last.
is that the case?

and even on the page you posted the plugin is not active ,
did you scan pages when you enabled the plugin?

ckubse 01-28-2015 06:08 PM

It may sound ironic but I guess the only template it doesnt' work with is yours Eximium/Grids. My website is a big mess now ... Installed another template based on Gantry and leaving alone the layout problems wich are mine( tried to add some Bootstrap grid classes to category layout) assigned it to a subcategory and as you see it works perfect. When I open Jcompress I see the number of the cached files ... etc.

neo 01-28-2015 06:15 PM

ok bud , I am not sure where you see the compressed files but I see none
meaning that you head is not cached , look here
your head
ours on

here take a look at activeapp ( our latest template ) source code and you will see what jcompress does
it could be that some plugin or extension you have is not lettings jcompress use the files but so far I see on all options you showed me, the plugin did not cache any of your pages.

PM admin info to me and I will take a look at it tomorrow.

ckubse 01-28-2015 06:55 PM

I know, but on my end as an admin with the gantry template at last, it looks like working. I see the normal page source and after a cache clear I must do a page refresh and I get the smaller stuff, with inline HTML and CSS&JS files compressed and minified in files like this cache/jcompress/jf_connecto/css/bcf8cc6c.php?version=24aaa20e.
Don't know what's wrong or what is changed to my Joomla install then, as the plugin it doesn't appear to be working on public. Also, I don't know if it has any connection to this but I have a plugin installed to log me in automatically on the front end when I'm logged in on the backend. Last time I checked it worked normal and now, on Joomla admin, oif I click log out from the front-end and then I log -out complettely , the frontend has a mind of it's own as I still appear to be logged in.
Don't want to bother but I'll give you my details to take a look when you can because the situation looks too Sci-Fi to be only told.

neo 01-29-2015 08:44 AM

ok i see that cache is on now , not sure what you did in mean time but looks ok
except the inline css that some extensions put inside the body tag, other than that looks fine.
the plugin is not touching any cookies/logins etc , so not sure what can affect your auto login or how that extension is constructed.

good thing is that I dont see js errors and everything seems to work fine

ckubse 01-29-2015 10:01 AM

I thought the same thing/ issue/whatever that is responsible for my frontend login plugin failure is the source of the problem for this too. That's why I told you about it. Never mind I also have a hosting from Hostgator and I have a 6 hours time offset because I am in East Europe. Everything is a nightmare on my side :))))

Well, I'm glad everything is working afterall. Thanks and btw, I've sent you yesterday a message with my credentials but I don't know if you got It because I see nothing on my forum account.

neo 01-29-2015 10:13 AM

I did not reply , just went in and took a look. And from plugins side and template side everything looks fine.

ckubse 01-29-2015 10:29 AM

Ok. :)
I'll finish customising my template and leave the plugin active till the final release.
Btw, I don't know much about joomla development but it would be an awesome feature to have the clear cache button in a more visible place, so the user doesn't have to open the plugin setting everytime he wants to clear it. Or maybe to put atlast something like "if plugin is active ... etc" in your framework and if the plugin is installed and active, the clear cache to be visible in theme admin. :)
Problem solved.

neo 01-29-2015 11:12 AM

finish the template customization first
than when you completely done , activate plugin , clear cache, scan pages and than go live with it.

All times are GMT -4. The time now is 05:14 PM.

Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.