Youjoomla Support Forums (https://www.youjoomla.com/joomla_support/index.php)
-   General questions (https://www.youjoomla.com/joomla_support/forumdisplay.php?f=17)
-   -   can sportrank use php 7 (https://www.youjoomla.com/joomla_support/showthread.php?t=16321)

kimberleym 12-03-2018 09:16 AM

can sportrank use php 7
 
Hi,

I am using sportrank template (the best one) with joomla 3.4.5 when my server change to php7 i got the 500 error.

can sport rank use php7 and what joomal update is max for sportrank?

Warm regards Kimberley

Are you sure your are posting in product assigned forum?: Yes

What is your CMS version?: Joomla 3.x

MySQL Version: 5.x

PHP version: 5.x

Link to installation: private

Have you edited any files? If yes tell us which ones.: No

Is this personal or client website?: Personal

neo 12-03-2018 09:27 AM

it can be module or plugin also, before going to php7 make sure all our extensions are the latest version.

kimberleym 12-03-2018 09:34 AM

hi neo, super quick response :)

my server is changing to php7 in 20 days and they will not support older version :(
how can i check your extension if they support php7?

warm regards Kim

neo 12-03-2018 10:18 AM

as far as I know they are all ready for php 7 even our demos are on it.
But you should test on local server. Download demo and install as t is. if everything is ok you are good to go. Otherwise advise what extension has issues and we will fix it.

kimberleym 12-03-2018 10:43 AM

thx neo,

The server was updated to php 7 and my site with sportrank template joomla 3.4.5 version got the 500 error and i cant login or nothing.

so i wonder if i should update joomla, theme or extensions?

Regards Kim

neo 12-03-2018 10:52 AM

first thing that should have been updated is Joomla itself
than every extension and template and than php switch

kimberleym 12-03-2018 01:10 PM

thx Neo,

so sportranks will work with joomla 3.9, with no issue?

neo 12-03-2018 01:45 PM

here on 3.9.1 and php 7.2.11

http://take.ms/GW4CP

kimberleym 12-03-2018 02:00 PM

fantastic Neo,

i can see that i use framwork
Version 1.0.1 Initial Release
YJSG Version 1.0.16 Initial Release

can i still use that or can i update it on version of joomla i use now and tmeplate

neo 12-03-2018 02:40 PM

No no , you must upgrade to latest version.
Plugin is out for 4 years by now
https://www.youjoomla.com/joomla-ext...rk-plugin.html

kimberleym 12-04-2018 04:18 AM

aha :)

1. so i upgrade "YJSG Joomla Template Framework plugin"
2. i upgrade joomla to 1.6
3. upgrade php7

is that right?

kimberleym 12-05-2018 04:13 AM

Hi Neo.

i updated the framework and joomla to 3.6.5 and php 7.1 i get these errors on the page:

Code:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Yjsgcolor has a deprecated constructor in /home/schartauphp7/public_html/templates/sportranks/yjsgcore/lib/yjsg_color.php on line 43
Code:

Helper::modYJLiveSearchItems() should not be called statically in /home/schartauphp7/public_html/modules/mod_yj_live_search/mod_yj_live_search.php on line 49
Code:

Deprecated: Non-static method YJMediaSliderHelper::YJMediaSliderItems() should not be called statically in /home/schartauphp7/public_html/modules/mod_yj_media_slider/mod_yj_media_slider.php on line 26
Code:

Deprecated: Non-static method YJmeHelp::YJmeItems() should not be called statically in /home/schartauphp7/public_html/modules/mod_yj_newsflash5/mod_yj_newsflash5.php on line 67

neo 12-05-2018 06:06 AM

You have an old template
This is current template v1.0.5 folder structure
http://prntscr.com/lqzb0n and core has been moved to Yjsg plugin 4 years ago

neo 12-05-2018 06:18 AM

also all modules that you have should be updated.
I tested template on my end it works fine on 7.x
will update demo today for 3.9.x but all in all everything works n our demo site
which is php7

neo 12-05-2018 06:20 AM

The way to update from joomla before 3.6.5 is

Update Joomla to 3.6.5 while on php 5.x
Update all templates and extensions
Update Joomla to 3.9.1
Switch to php7.x

neo 12-05-2018 07:57 AM

all tested ,
there were few modules notices in the demo but reinstall modules fixes those.
I updated the demo to latest J 3.9.x install and everything works fine.

kimberleym 12-05-2018 12:36 PM

Hi Neo,

i did exactly like that and i have some modules not working now, where do i find them? will the modules keep the existing settings after reinstall?

neo 12-05-2018 01:43 PM

In extensions download section
https://www.youjoomla.com/joomla-extensions.html

kimberleym 12-06-2018 02:18 AM

Hi Neo,

as i only want to update 3 extensions what is cheapest package?

Warm regards K

neo 12-06-2018 06:37 AM

Gold
https://www.youjoomla.com/join/signup.php?&product_id[]=9

Branding removal instructions are in your member download area
https://www.youjoomla.com/join/member.php?tab=downs


All times are GMT -4. The time now is 12:49 PM.

Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.