Youjoomla Support Forums (https://www.youjoomla.com/joomla_support/index.php)
-   YJSG Template Framework Plugin (https://www.youjoomla.com/joomla_support/forumdisplay.php?f=269)
-   -   Can't get MegaMenu working (https://www.youjoomla.com/joomla_support/showthread.php?t=12754)

neo 06-27-2014 03:20 PM

there are min 2 additional frameworks that might be overriding
ZL Framework
NoNumber framework are 2 that "might"

can you PM me the admin info please let me take a look , and advise everything you have changed/removed

neo 06-27-2014 05:27 PM

it is no number framework
they override module default class
to be precise it is
System - NoNumber ReReplacer
can you pack that plugin and send ti to me youjoomla at gmail
they are doing something funny there

actually pack and send all of their plugins please
Screenshot by Lightshot
since your cache is messing with me and I cant nail down wich one is it exactly

you have so many things on that site that you will never use, dont wonder if you end up having plenty of issues,

your template manager is already broken
Screenshot by Lightshot

neo 06-27-2014 05:36 PM

definitely
they dont even wait for any event and load own version of module helper

Screenshot by Lightshot
Screenshot by Lightshot


this way they override anyone's try to extend the module class
I honestly cant fight with those.
We do our best to go by J standards but with coding practices like this there is nothing we can do unless we start doing things like that on our own

in our framework we wait for render since it is the earliest event we should use

Screenshot by Lightshot

if you really want to use their extension than I suggest you copy the html overrides for all modules from plugin
Screenshot by Lightshot
and place them in templates html folder

go to plugins\system\yjsg\includes\html and copy files over to template

enzo02 06-27-2014 07:16 PM

Hi Neo,

thanks again for your fast reply

that's quite a lot of information...I try to sort it out.
Actually I think it's just the Advanced Module Manager.

It's an old version. Maybe an update can help.

I will let you know after the update

cheers
enzo

enzo02 06-28-2014 09:27 AM

Hi Neo,

Still not working after the update of Advanced Module Manager.

May I reference to this thread and contact the creator of Advanced Module Manager?

Despite the problems, this Module Manager is usefull and one of the top rated extensions in jed.

Maybe he has some ideas to overcome these problems.

There is an other Module Manager called MetaMod which seems to work.
I will check this one out

cheers
enzo

neo 06-28-2014 10:15 AM

yes please do , you can tell them that it would be great if they can move the call for JmoduleHelper from_construct inside the onAfterRender method, this way we all can work together

enzo02 06-28-2014 05:31 PM

Hi Neo,

This is the answer from Peter about the Advanced Module Manager

----
No, I see no way they can work together.
If one overrules the module helper, then the other can't.
----

neo 06-29-2014 10:48 AM

we are extending it not overriding the full class.
but either way have you tried moving html folder to template from plugin?

enzo02 06-29-2014 01:24 PM

Nope, but I Will try !
Was testing Metamod which is promising.
It also throws some php errors, but basically it's working.

Will give Feedback after moving the folders to template

enzo02 06-30-2014 03:25 PM

Hi Neo,

copying the files in plugins\system\yjsg\includes\html\... to template to template html folder works !

So you can choose between the standard way by using MetaMod or the "override" way with Advanced Module Manager.

Nevertheless, copying the files to the template html folder does not seem to be a sustainable solution

thanks Neo

cheers
Alexandra


All times are GMT -4. The time now is 09:28 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.