Youjoomla Support Forums (https://www.youjoomla.com/joomla_support/index.php)
-   YJSG Template Framework Plugin (https://www.youjoomla.com/joomla_support/forumdisplay.php?f=269)
-   -   [SOLVED] Warning: Illegal string offset (https://www.youjoomla.com/joomla_support/showthread.php?t=13076)

tonyfla 09-19-2014 09:44 AM

[SOLVED] Warning: Illegal string offset
 
I am getting the below error after updating to yjsg 2.01, while attempting to view an ohanah event.

Warning: Illegal string offset 'data' in /var/www/html/libraries/koowa/template/filter/style.php on line 106

Screenshot by Lightshot

Are you sure your are posting in product assigned forum?: Yes

What is your CMS version?: Joomla 3.x

MySQL Version: 5.x

PHP version: 5.x

Link to installation: South Florida Slam 3on3 Team Payment - South Florida Cobras

Have you edited any files? If yes tell us which ones.: No

Is this personal or client website?: Personal

neo 09-19-2014 10:07 AM

I think they have same issue we had with attribs variable from joomla
Illegal string offset - Page 2 - Youjoomla Support Forums


https://github.com/gagarine/ohanah/b...style.php#L106

neo 09-19-2014 10:19 AM

I am trying to contact them and get the extension so that we can test.

tonyfla 09-19-2014 10:32 AM

I reverted to a snapshot and added updated the plugin using the Joomla Update and the error is no longer displaying on the page.

neo 09-19-2014 10:54 AM

the files are same anywhere but il test more once ( if ) they send me the extension.

tonyfla 09-19-2014 01:05 PM

I hope they do provide the extension, their product mess with template all over. The site menus do not work on their pages.

neo 09-19-2014 02:17 PM

it has been couple hours already and i have no reply from them

neo 09-19-2014 03:14 PM

ok , only issue I found was their module injector wich was overriding our JModuleHelper.
But luckily they knew what they are doing and have provided the option for it

this is required for yjsg and ohanah to work together
Screenshot by Lightshot


Screenshot by Lightshot
Screenshot by Lightshot

other than this I did not find a problem

if there is a specific setting you would like me to test please advise

tonyfla 09-21-2014 07:12 PM

that worked. thanks. Once i made the change the sub menus started to work


All times are GMT -4. The time now is 05:49 PM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.