Hello there! Welcome to Youjoomla Support Forums

We are Web Development Company specializing in Joomla Templates , Joomla Extensions and WordPress Themes development . You are not able to see some forum threads due to your memberhip level. To unlock all forums and special customer support please take few moments to signup . If you are just searching for free joomla templates , or free joomla extension support simply head to our Free Joomla Support forums and open a new thread. Our moderators will help you as soon as possible. To spead up the response time please take few seconds and go over forum rules

Have fun!

[SOLVED] Zend oprimizer and joomla,

07-26-2009, 07:09 AM
# 1 (permalink)
smsperty
I had iocube for php4 installed when I parsed to php5 I could not install ioncube for php5. I contacted my host and they told me zend
optimizer is not properly installed.You should install zend optimiser.
I tryed to install Zend optimiser but failed. I did as it says in the instruction, run /install and / install-tty but still fail and get this error:

Code:

#!/bin/sh
#
#   +----------------------------------------------------------------------+
#   | Zend installation script                                             |
#   +----------------------------------------------------------------------+
#   | Copyright (c) 1998-2005 Zend Technologies Ltd.                       |
#   +----------------------------------------------------------------------+
#   | The contents of this source file is the sole property of             |
#   | Zend Technologies Ltd.  Unauthorized duplication or access is        |
#   | prohibited.                                                          |
#   +----------------------------------------------------------------------+
#   | Authors: Michael Spector <michael@zend.com>                          |
#   |          Anya Tarnyavsky <anya@zend.com>                             |
#   +----------------------------------------------------------------------+
#

INSTALL_DIR=./zui_files
PHP_SCRIPT=install.php
ZEND_TMPDIR=/tmp/zend_install.$$
ORIGINAL_CWD=`pwd`
CALLING_SCRIPT=$0

error ()
{
   echo "ERROR: "$1
   exit
}

freebsd_libc_patch()
{
   if [ ! -e /usr/lib/libc.so.3 ]; then
      if [ -e /lib/libc.so.5 ]; then
         ln -s /lib/libc.so.5 /usr/lib/libc.so.3
      elif [ -e /usr/lib/libc.so.5 ]; then
         ln -s /usr/lib/libc.so.5 /usr/lib/libc.so.3
      elif [ -e /usr/lib/libc.so.4 ]; then
         ln -s /usr/lib/libc.so.4 /usr/lib/libc.so.3
      elif [ -e /usr/lib/libc.so ]; then
         ln -s /usr/lib/libc.so /usr/lib/libc.so.3
      fi
   fi
      
   if [ ! -e /lib/libm.so.2 ]; then
      if [ -e /lib/libm.so.3 ]; then
         ln -s /lib/libm.so.3 /lib/libm.so.2
      elif [ -e /lib/libm.so ]; then
         ln -s /lib/libm.so /lib/libm.so.2
      fi
   fi
}

darwin_libdl_patch()
{
   if [ -f libdl.dylib ]; then
      if [ ! -d /usr/local/lib ]; then
         mkdir -p /usr/local/lib 2> /dev/null || error "Cannot mkdir: /usr/local/lib"
      fi
      if [ ! -e /usr/local/lib/libdl.dylib ]; then
         cp -f libdl.dylib /usr/local/lib/libdl.dylib
      fi
   fi
}

create_php_ini()
{
   if [ ! -f php-install.ini ]; then
      touch php-install.ini
      if [ -f ../data/ZendOptimizer.so ]; then
         echo 'zend_extension=../data/ZendOptimizer.so' >> php-install.ini
      fi
      echo 'memory_limit=100M' >> php-install.ini
   fi
}

check_root_permissions()
{
   ID="id -u"
   MYUID=`$ID 2> /dev/null`

   if [ -z "$MYUID" ]; then
      MYUID=`/usr/xpg4/bin/$ID 2> /dev/null`;
   fi

   if [ ! -z "$MYUID" ]; then
      if [ $MYUID != 0 ]; then
         error "You need root privileges to run this script!";
      fi
   fi
}

cleanup ()
{
   if [ ! -z "$ZEND_TMPDIR" ] && [ -d "$ZEND_TMPDIR" ];
   then
      for saved_config in `ls $ZEND_TMPDIR/saved/_* 2> /dev/null`;
      do
         orig_config=`basename $saved_config | sed 's/_/\//g'`
         nbytes_orig=`wc -c $orig_config | sed 's/^ *//' | cut -d' ' -f1`
         nbytes_saved=`wc -c $saved_config | sed 's/^ *//' | cut -d' ' -f1`

         # If original config file was changed, restore it:
         if [ ! -s $orig_config -o $nbytes_orig -lt $nbytes_saved ]; then
            rm -f $orig_config
            mv $saved_config $orig_config
         fi
      done
      rm -rf $ZEND_TMPDIR
   fi

   stty echo
   clear
   echo
   echo "Installation script was aborted. The process was NOT completed successfully."
   echo
   exit 1
}

check_root_permissions

# Go to the package directory:
if [ ! -d $INSTALL_DIR ]; then
   cd `dirname $0` 2> /dev/null
fi

cd $INSTALL_DIR 2> /dev/null || error "Cannot CD to install directory: "$INSTALL_DIR

if [ ! -f ./php -o ! -x ./php ]; then
   error "Executable file: ./php doesn't exist in "$INSTALL_DIR
fi

[ `uname` = "FreeBSD" ] && freebsd_libc_patch
[ `uname` = "Darwin" ] && darwin_libdl_patch

create_php_ini

trap 'cleanup' 2 15

# execute the main PHP script
ZEND_TMPDIR=$ZEND_TMPDIR CALLING_SCRIPT=$CALLING_SCRIPT ORIGINAL_CWD=$ORIGINAL_CWD \
   ./php -c ./php-install.ini -q $PHP_SCRIPT $@

Contacted again them and they told me:
"Remove all the previous
files you have on the old ZendOptimizer and reinstalling it back would
help the issue."
I have installed nothing.
Has it been installed with joomla?
If yes how can I remove it ?
07-26-2009, 04:34 PM
# 2 (permalink)
neo
is this dediicated box? if shared all you need is path to IQ loaders in php.ini which you usually get from your host, no need to install anything, and if dedicated your hosting company should have this compiled for you before you started. who are you hosting with ?
07-26-2009, 04:38 PM
# 3 (permalink)
neo
here is wamp example ,

line added in php.ini at the bottom of the file ,

zend_extension_ts = C:\wamp\ioncube\ioncube_loader_win_5.2.dll

in your example you would just change path if is shared ,

if dedicated

this is usual path of them ,

; Directory in which the loadable extensions (modules) reside.
extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"
zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so"
zend_extension_ts="/usr/local/IonCube/ioncube_loader_lin_5.2_ts.so"


simply download the loaders

PHP Encoder, protection, installer and performance tools from ionCube: Loader Download

login in your server as root ,

and check if they are in folders as described ,
if they are not there , extract the download and move them in , than
tell php.ini where they are

I would still suggest to check with your host since this is a must on dedicated boxes
text in red describes what OS it is , linux or windows
07-26-2009, 04:44 PM
# 4 (permalink)
neo
o and install script , is actualy moving them in the folders above , so if you move them or the script it is same ,

script you used might have not had root privileges if you loged in as cpanel user and not as root , so you will not be able to use it,

again if shared hosting , they MUST tell you were the libs are so you can modify your php.ini
07-27-2009, 03:01 PM
# 5 (permalink)
smsperty
Thank you neo with your great support,
My problem goes like this:
I have a home package with 1and1.
They use php4 as a defauf and if you want to parse to php5 you need to add a line to htaccess.
So when fist when I needed ion cube i had php4 and here are the steps i took to install it
Upload iocube
Run ioncube helper
Create the php.ini file with the line:
zend_extension=/homepages/**/d24***/htdocs/sitefolder/ioncube_loader _lin_4.4.so
Run:
http://www.mysite.com/ioncube/ioncube-encoded-file.php
and I get this information:
This file has been successfully decoded. ionCube Loaders are correctly installed.
If I put the line in htccess and parse to php5 have to install
ioncube for php5
Run the helper and see the php.ini insstructions
Go to php.ini and change the loader from 4.4 to 5.2 as follows:

zend_extension=/homepages/**/d***/htdocs/sitefolder/ioncube_loader _lin_5.2.so
Run http://www.mysite.com/ioncube/ioncube-encoded-file.php
and get this:
This encoded file cannot be run. Please run the file
ioncube-loader-helper.php for more information.
If I run the help is the same as from begining

Maybe it dont work with php5 in my server and they try to hide it couse its been months i am fighting with this couse before some months they also asked me for my ftp account and did not installed it adn told me me ioncube is out of out support contact ioncube.
also creatd a support tickit there and they too after some advises told contct your server.

What makes me wander whe they said uninstall send optimizer...
I have not installed it and does it get installed when joomla installed...

I also tryed your advise neo like this:

extension_dir = "/path/php/extensions/no-debug-non-zts-20060613"
zend_extension="/path/IonCube/ioncube_loader_lin_5.2.so"
zend_extension_ts="/path/IonCube/ioncube_loader_lin_5.2_ts.so"

And got the same error
Thank again for your support
07-27-2009, 03:08 PM
# 6 (permalink)
neo
right , they use fake php5 method , it is actually not phrased as php5 but it is still php4 using some php5 libs to run the code for your site , but think , if the server stays at php4 as default than you should use php4 loaders since these will stay as the default php version , , 1and1 are completely fake and I would run If I where you,


read this about using htaccsess override for php versions

Joomla! &bull; View topic - FAQ: How to switch to PHP5 using .htaccess
07-27-2009, 04:33 PM
# 7 (permalink)
smsperty
Yes i use this file to parse to php5:
AddType x-mapp-php5 .php
And if I go to system info it says the php version 5.2.10
With php4 ioncube works good but there are some componets that needs php5
and if I add that line which parse to php5. the componet which needs ioncube give me a arror to all the site and saying to install ioncube for php5.
So I have to unistall that componet to make my site work. I have spent 120 euro for buying it.
07-27-2009, 04:37 PM
# 8 (permalink)
neo
ok , 1and1 must tell you where the php5 ioncube loaders are , you canot install them by yourself , but try this tweak , download the cube loaders for php5 and place them ABOVE public_html folder , than in php.ini,

extension_dir = "/path/php/extensions/no-debug-non-zts-20060613"
zend_extension="/path/IonCube/ioncube_loader_lin_5.2.so"
zend_extension_ts="/path/IonCube/ioncube_loader_lin_5.2_ts.so"


give zend the path to them , which I guess it would be

/home/cpanle_username/IonCube/ioncube_loader_lin_5.2_ts.so
07-27-2009, 04:40 PM
# 9 (permalink)
neo
if this is your package

1&1 Home package $4.99/mo.

than you are on shared hosting and you canot install any server scripts. only server admin can who has access as root,

I cant believe that their techs dont know where libs are
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Members Login

Username
Password