Hello there! Welcome to Youjoomla Support Forums

We are Web Development Company specializing in Joomla Templates , Joomla Extensions and WordPress Themes development . You are not able to see some forum threads due to your memberhip level. To unlock all forums and special customer support please take few moments to signup . If you are just searching for free joomla templates , or free joomla extension support simply head to our Free Joomla Support forums and open a new thread. Our moderators will help you as soon as possible. To spead up the response time please take few seconds and go over forum rules

Have fun!

[SOLVED] Video shows up blank but after clicking 'next' then 'previous' it works.

06-28-2011, 08:17 PM
# 1 (permalink)
blindMoe
This is fixed.. it was because the module was published twice on the same page ( once via an article and once in a module position ). Disabling it in one of them fixed it. Feel free to close this thread.

Thanks for the great product!


I have a 'View Photos' and a 'View Videos' link on a page. Both use the joomla module to open a gallery for the videos and the photos. The two galleries are set in the same group but they have different links. The problem I am running into happens when I first click the 'View Videos' link. The lightbox opens up normally but the video does not show. If I click 'Next' in the nav of the lightbox the second video shows up just fine and then I can click 'Previous' to go back to the first, which then works.

I don't receive any javascript errors in the console and I don't believe it is a CSS issues since it works fine if I go next/prev.

I looked at the source and it looks like MBot is creating two div's with the same id="mbOverlay" and I am thinking this may be the problem.

Is there a way for me to tell MBot to use a unique id for its' container divs?

My code looks like this:

PHP Code:

<li>
{
mbox:medical/Medical-01.jpg|id=m2234234|thumbnone=0|group=nothumb|title=Medical|txt=<img src="/images/buttons/btn_view_photos.png" alt="" />}
{
mbox:medical/Medical-2.jpg|nothumb=thno|group=nothumb|thumbnone=13|title=Medical 2}
{
mbox:medical/Medical-3.jpg|nothumb=thno|group=nothumb|thumbnone=1|title=Medical 3}
{
mbox:medical/Medical-4.jpg|nothumb=thno|group=nothumb|thumbnone=2|title=Medical 4}
{
mbox:medical/Medical-5.jpg|nothumb=thno|group=nothumb|thumbnone=3|title=Medical 5}
{
mbox:medical/Medical-6.jpg|nothumb=thno|group=nothumb|thumbnone=4|title=Medical 6}
{
mbox:medical/Medical-7.jpg|nothumb=thno|group=nothumb|thumbnone=5|title=Medical 7}
{
mbox:medical/Medical-8.jpg|nothumb=thno|group=nothumb|thumbnone=6|title=Medical 8}
{
mbox:medical/Medical-9.jpg|nothumb=thno|group=nothumb|thumbnone=7|title=Medical 9}
{
mbox:medical/Medical-10.jpg|nothumb=thno|group=nothumb|thumbnone=8|title=Medical 10}
{
mbox:medical/Medical-11.jpg|nothumb=thno|group=nothumb|thumbnone=9|title=Medical 11}
{
mbox:medical/Medical-12.jpg|nothumb=thno|group=nothumb|thumbnone=10|title=Medical 12}
</
li>
<
li>
{
mbox:http://www.youtube.com/watch?v=4yAq0ytvcvY|853|510|thumbnone=vid0|group=nothumb|title=Making it Work|txt=<img src="/images/buttons/btn_view_videos.png" alt="" />}
{mbox:http://www.youtube.com/watch?v=8EWbjlmIyog|853|510|nothumb=thno|group=nothumb|thumbnone=vid1|title=Delivering a Baby}
</li
Any help would be greatly appreciated, I think I may try to just use a uniq() php id to create the ID's in use by the module but I don't want to dive in if I don't need to.
06-28-2011, 09:42 PM
# 2 (permalink)
orion_
Thank you for the update and sharing information for others
Thread Tools
Display Modes

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Members Login

Username
Password