Hello there! Welcome to Youjoomla Support Forums

We are Web Development Company specializing in Joomla Templates , Joomla Extensions and WordPress Themes development . You are not able to see some forum threads due to your memberhip level. To unlock all forums and special customer support please take few moments to signup . If you are just searching for free joomla templates , or free joomla extension support simply head to our Free Joomla Support forums and open a new thread. Our moderators will help you as soon as possible. To spead up the response time please take few seconds and go over forum rules

Have fun!

Problems with params.ini

07-29-2010, 09:47 PM
# 1 (permalink)
davec1031
I had a problem with the params.ini file resetting to non-writable, where it would basically revert back to 555, and not allow any more edit. I tracked that down to a bug with a component in the administrator/components/com_templeates folder, the Controller.php file was (if error, but i have seen none) it will revert to 555.. I changed that to 644, leaving it open to edit again.

Now the problem is, that i set it to leftblock middleblock rightblock , and it saves, but give it about 5 min and it's back to leftblock rightblock, middleblock..

Anyone have any idea how to fix that? The params.ini file now defaults to 644 no matter what i do because i changed it in the controller. but still..
07-30-2010, 07:28 AM
# 2 (permalink)
neo
non-writable is just security message , you should still be able to change settings. post link to your site please and advise what exact settings you have changed. Widths canot simply change on their own.
Watch for Specific Item ID widths as well since this is different setting
07-30-2010, 01:24 PM
# 3 (permalink)
davec1031

Code:

			// Try to make the params file unwriteable
			if (!$ftp['enabled'] && JPath::isOwner($file) && !JPath::setPermissions($file, '0644')) {
				JError::raiseNotice('SOME_ERROR_CODE', JText::_('Could not make the template parameter file unwritable'));
			}

			if (!$return) {
				$mainframe->redirect('index.php?option='.$option.'&client='.$client->id, JText::_('Operation Failed').': '.JText::sprintf('Failed to open file for writing.', $file));
			}
		}
I changed that to 644, instead of 555. and a few others in the \administrator\components\com_templates\controller .php file. A fix i saw in the joomla forums, but it still isn't working.

Basically the site at Welcome to PC Doc Computers RI the layout should be left block, middle block, right block. But for some reason it keeps going back to middle block, left block, right block, (the default?).

It seems whenever the session times out or something, not sure, it defaults back to that layout.

I was thinking about changing the file again to 755, thinking it needs execute permission to run and that is why it keeps defaulting back.. not sure tho..

P.S. I am trying that fix i said, changing it to 755. so it might look normal, give it 10 min or so, and hit refresh..

Second Edit: Nope it reverted back, so i will change that file back to original, so it will be like a fresh install. That is what i did, install, get the template, and this was the result. I am using the newest joomla 1.5.20.
07-31-2010, 02:35 AM
# 4 (permalink)
shedetails
hi there, i am new to joomla, but know a little bit about making updates/changes. i too am having the same identical problem. my system timed out on me a couple of times and that when i noticed i started having the problem. i show no other errors besides this: The parameter file /templates/yougrids/params.ini is unwritable!

when i log off, then back on again, uninstall, reinstall (without making any changes) the params.ini show writable. but soon as i start to make changes to the template is goes unwritable and doesn't save any of the changes i made before it became unwritable. definitely interested in a fix or advice to fix. this is a new project for me and i'm on a crazy deadline.

by the way i'm using the new template: YOUGrids
07-31-2010, 07:08 AM
# 5 (permalink)
neo
this is a very common bug and it is not template releated. nothing to freak about if your settings change is taking affect ,

if you want to go step further try to enable your ftp layer under > site > global configuration and make sure that the SITE_OWNER user is the owner of the files , make sure Apache ( root) is not the owner

and please for further posts , read forum rules and post system information so we can give you detail instructions
07-31-2010, 07:21 AM
# 6 (permalink)
neo
Quote:
Originally Posted by davec1031

Code:

			// Try to make the params file unwriteable
			if (!$ftp['enabled'] && JPath::isOwner($file) && !JPath::setPermissions($file, '0644')) {
				JError::raiseNotice('SOME_ERROR_CODE', JText::_('Could not make the template parameter file unwritable'));
			}

			if (!$return) {
				$mainframe->redirect('index.php?option='.$option.'&client='.$client->id, JText::_('Operation Failed').': '.JText::sprintf('Failed to open file for writing.', $file));
			}
		}
I changed that to 644, instead of 555. and a few others in the \administrator\components\com_templates\controller .php file. A fix i saw in the joomla forums, but it still isn't working.

Basically the site at Welcome to PC Doc Computers RI the layout should be left block, middle block, right block. But for some reason it keeps going back to middle block, left block, right block, (the default?).

It seems whenever the session times out or something, not sure, it defaults back to that layout.

I was thinking about changing the file again to 755, thinking it needs execute permission to run and that is why it keeps defaulting back.. not sure tho..

P.S. I am trying that fix i said, changing it to 755. so it might look normal, give it 10 min or so, and hit refresh..

Second Edit: Nope it reverted back, so i will change that file back to original, so it will be like a fresh install. That is what i did, install, get the template, and this was the result. I am using the newest joomla 1.5.20.
I see your layout set at 1
which is left-mainbody-right , give me few min for troubleshooting , seems like a bug , will post back with result
07-31-2010, 10:20 AM
# 7 (permalink)
neo
we are working on this bug , sorry but seems that it affects all switchers except font, for time being you can manualy change default layout so you can work . there will be an update that will change 1 file only so it wont affect you much .

to change default please go to

templates/yougrids/yjsgcore/yjsg_stylesw.php

line 171

Code:

$valid_layout = 2;
change to

Code:

$valid_layout = 1;

once we fix this bug I will update this thread and download files
07-31-2010, 02:39 PM
# 8 (permalink)
neo
try this file ,


replace yougrids/yjsgcore/yjsg_stylesw.php with file attached ,

unzip first

please advise if ok
Attached Files
File Type: zip yjsg_stylesw.zip (1.7 KB, 12 views)
07-31-2010, 06:01 PM
# 9 (permalink)
davec1031
Quote:
Originally Posted by neo
try this file ,


replace yougrids/yjsgcore/yjsg_stylesw.php with file attached ,

unzip first

please advise if ok
Ok put that file in, i will keep it on that theme and hopefully it doesn't change back again!

Thank you for the quick response!
07-31-2010, 10:19 PM
# 10 (permalink)
davec1031
That fix defiantly did it!! it's working perfect now!! No other bugs as far as i can see, loving the customization you can do with this. Now i can have my banners and such wherever i want them without too much trouble, and adding things is going to be so easy now!

Thanks for getting back to me so fast and straightening out this bug quick!

Proudly sporting that banner in the footer, for sure!
Thread Tools
Display Modes

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Members Login

Username
Password