Hello there! Welcome to Youjoomla Support Forums

We are Web Development Company specializing in Joomla Templates , Joomla Extensions and WordPress Themes development . You are not able to see some forum threads due to your memberhip level. To unlock all forums and special customer support please take few moments to signup . If you are just searching for free joomla templates , or free joomla extension support simply head to our Free Joomla Support forums and open a new thread. Our moderators will help you as soon as possible. To spead up the response time please take few seconds and go over forum rules

Have fun!

Getting Error - allow_call_time_pass_reference

03-26-2008, 10:06 PM
# 1 (permalink)
anandethiraj
Hi,
I am getting the following error.

Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in C:\\Program Files\\Apache Software Foundation\\Apache2.2\\htdocs\\joomla\\modules\\mo d_tab_news1\\mod_tab_news1.php on line 277

I have set the following variable to true in PHP.ini file. but still i am getting the error. I am working in local system.

Please let me know to proceed further.
03-27-2008, 07:19 AM
# 2 (permalink)
motorbikethailand

I have also been trying every method mentioned on the forum to try to rid my site of the above error also and regardless of what I do to the ini file I cannot get it sorted for both the slider and the news tab.

Please can someone help out on this?
03-27-2008, 08:38 AM
# 3 (permalink)
anthonyh
========================
Anand Ethiraj wrote:
[quote]

I have set the following variable to true in PHP.ini file. but still i am getting the error. I am working in local system.
quote]
========================



Hi,

Im having the same problem without getting any solution.
Can you please tell me if the PHP.ini file you are mentioning is in the root directoty? I found my PHP.ini but couldnt find the code but in the php.ini in my root folder there is no allow_call_time_pass_reference or anything that even looks like it. Is there only one php.ini in this whole directory?

Thanks.
03-27-2008, 08:58 PM
# 4 (permalink)
anthonyh
Hi, after waiting so long for a solution I went searching and searching. After going to the file where the error is referenced to I deleted the & sign in that line and the warning was removed.
In my other warning messages I did the same. Just went to the file and line mentioned and deleted the & sign.

My warnings are all gone so I hope that this was the solution to the problem.
03-27-2008, 09:31 PM
# 6 (permalink)
neo
I made this post a sticky for other users, thnx. Dmitri is gone for couple months , so I had to play with errors . I am template developer and he works on modules. however good community is much better that couple guys alone.
03-27-2008, 09:46 PM
# 7 (permalink)
anthonyh
My pleasure. Glad I could help and hope the others with the same question will look at this and solve it.
03-28-2008, 01:11 PM
# 9 (permalink)
anthonyh
Ok. thanks. Do I need to do something? Like download the template again to get the updated mods? Or only the 2 mods I edited? Are am I ok for now?
Thread Tools
Display Modes

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Members Login

Username
Password