Youjoomla Support Forums (http://www.youjoomla.com/joomla_support/index.php)
-   YJ Pop login (http://www.youjoomla.com/joomla_support/forumdisplay.php?f=122)
-   -   Failed Login message (http://www.youjoomla.com/joomla_support/showthread.php?t=9447)

shreejit_k 12-18-2011 06:15 PM

Failed Login message
 
Hi,

I have a custom template and I have incorporated YJPop Login module into it. I have a small problem with Failed Logins whereupon the users DO NOT get an "error message" and get redirected onto an empty page.

What I am after is to show the users an error message of some sort when they enter wrong credentials/

How can I sort this issue out ?

Thanks for your help in advance.

Regards,

SK

joomlagold 12-18-2011 11:18 PM

read forum rules again please , we need more info about your system and links please

Youjoomla Support Forums - Forum Rules

shreejit_k 12-19-2011 08:01 PM

Thanks for your response Joomlagold. I have PMed you the website address. I hope you can understand the reason I sent it as a PM. The site is still under construction and is a test project only and we dont want others accessing it yet.

I am using Joomla 1.7. Logging in with the correct login details work fine but if you enter wrong credentials then you are led to an empty page. Please let me know if you need more info.

I have made minor custom changes where I have changed the div class "popping links" to something else. Apart from that the code is the same as it is. Thanks for your help.

joomlagold 12-19-2011 08:17 PM

not sure I see the problem , on logout im being redirected to index.php?Itemid=103 but I see session holding so there is something about this , im forwarding to developer and I think this is same issue

neo 12-19-2011 08:47 PM

i tested wrong credentials and I stayed on index.php, no white pages ,
I suggest you clean your cache

shreejit_k 12-19-2011 09:33 PM

Thanks neo. I didnt realise you would be testing it this soon. I was playing around with a redirection plugin. I have disabled that plugin so you can have a crack at it once again.

Wrong credentials now will take you to a blank page. :)

joomlagold 12-19-2011 10:03 PM

funny one.
index.php?Itemid=103
is dead now and is dead with or without the redirect

what did you select as redirect link ? and is this link ok
index.php?Itemid=103

go to Menu Main menu and find itemid 103 tell us what it is

shreejit_k 12-19-2011 11:53 PM

itemid 103 is the Survey Page you go to upon logging in using the credentials I provided...so apparently on entering wrong credentials users are getting redirected to that same page. Survey page is not accessible to all users thats why I suppose we come across an empty page.

I remember when I tried this module out with one of the default templates that comes with Joomla, users get a message saying something like "Username and Password are not correct, please check details" - something along these lines, not sure what the exact statement was....Somehow it doesnt display that with my custom template.

Login Redirection Page - SURVEY
Logout Redirection Page - HOME

joomlagold 12-20-2011 12:09 AM

I would say you dont have module positions usable or published on that page

shreejit_k 12-20-2011 12:32 AM

Hmm so what do you think I should do ? I think when I tested this previously with a different template and entered wrong details, I got redirected to a separate page that displayed an error message.

Is there a way to accomplish that with my custom template ?


All times are GMT -4. The time now is 09:17 AM.

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.