Youjoomla Support Forums (http://www.youjoomla.com/joomla_support/index.php)
-   You!Bubble (http://www.youjoomla.com/joomla_support/forumdisplay.php?f=164)
-   -   Adding Cufón to You!Bubble (http://www.youjoomla.com/joomla_support/showthread.php?t=8712)

glrende 07-15-2011 02:25 PM

Adding Cufón to You!Bubble
 
Hi all! I have start using You!Bubble template for my web project and I like to say that is very powerfull and nice.

I would like to add Cufón function to the template, to use my own font like I do on another project (added Cufón manually in index.php). My installation is Joomla 1.5.23 es, clean (no example data installed) just the template and Youjoomla Piecemaker Module for Joomla 1.5x.
I browsed the forum looking for instructions to do this and I found the post "Adding Cufon Fonts in YJSG Templates" really interesting, but I think You!Bubble template haven´t got Cufón built in because cannot find the folders mentioned on the post.

So I founded a plugin from Keashly: kc_cufon and followed instructions from them to make it work. Well, the fact is that the javascript is not loading for the plugin so is not working.
I also tryed to install it manually (like on the other project) adding this lines to index.php just before </head>:
PHP Code:

<!-- Cufon -->
<script type="text/javascript" src="<?php echo $path ?>/js/cufon-yui.js"></script>
<script type="text/javascript" src="<?php echo $path ?>/js/myradpro.font.js"></script>

<script type="text/javascript">
    Cufon.replace('h1, h2, h3, h6, #nav');
</script>

But the problem is the same, my bug inspector says that javascript is not loading.
Also tryed disabling Youjoomla Piecemaker Module for Joomla 1.5x without any effect. Tryed on IE8, Opera 11.50, Firefox, Safari...

Any idea how to make it work?
Thank you very mutch in advance.

maggoo 07-15-2011 03:06 PM

The tutorial is about adding extra cufon fonts to yjsg powered templates, since those already are capable of cufon. Bubble isn't on yjsg.

KC cufon is a great plugin, but it doesn't work on local installs but works perfectly on the web. So my guess is you are working on xamp or wamp, right?

glrende 07-15-2011 03:42 PM

Hi, thanks for quick response.

Yes, I´m working on WAMP 5, but I have various Joomla 1.5.23es projects with the lines in index.php installed as mentioned above and they works fine. So, why isn´t working the same on Bubble?
I use Opera 11.50 Element Inspector and it says that the javascript has not been loaded, nor using KC plugin nor on PHP directly added lines and files.

So I figured out that is an issue with the template.

maggoo 07-15-2011 04:20 PM

Just to be clear, we can not possibly support the entire JED, and/or customizations for free templates. And as said, and as can be found on the page of the plugin, online it works just fine.


All times are GMT -4. The time now is 02:05 PM.

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.