Youjoomla Support Forums (http://www.youjoomla.com/joomla_support/index.php)
-   YouGrids (http://www.youjoomla.com/joomla_support/forumdisplay.php?f=171)
-   -   YJSG Template Manager labels Joomla 1.6 (http://www.youjoomla.com/joomla_support/showthread.php?t=7696)

neo 03-20-2011 06:35 AM

anyone that has lang issue , if you could , please pack the php.ini file from your server , this will help us nail the setting that is missing

artuspower 03-20-2011 06:53 AM

Apache 2.2.11, PHP 5.3.0

ossipenko 03-20-2011 10:50 PM

Quote:

Originally Posted by neo (Post 36339)
anyone that has lang issue , if you could , please pack the php.ini file from your server , this will help us nail the setting that is missing

While I trying upload attach .zip with filesize 53kB upload window writes
"Exceeds your quota by 3.2 KB."

artuspower 03-21-2011 11:54 AM

1 Attachment(s)
There you are.
Please remove the attachement after download.

neo 03-24-2011 07:38 AM

ok , there was a change from php 5.2.x to 5.3.x in parse_ini_file

changelog from 5.2.5 to 5.3.0:
o Added 3rd optional parameter to parse_ini_file() to
specify the scanning mode of INI_SCANNER_NORMAL or INI_SCANNER_RAW. In
raw mode option values and section values are treated as-is.
* Added parse_ini_string() function. (grange at lemonde dot fr,
Arnaud)
* Fixed bug #46347 (parse_ini_file() doesn't support * in keys).
(Nuno)
* Fixed bug #45384 (parse_ini_file will result in parse error with
no trailing newline). (Arnaud)
* Fixed bug #44842 (parse_ini_file keys that start/end with
underscore). (Arnaud)
* Fixed bug #44575 (parse_ini_file comment # line problems). (Arnaud)
* Fixed bug #45956 (parse_ini_file() does not return false with
syntax errors in parsed file).

and i finally have the same as you guys , il adjust the lang files and advise

neo 03-24-2011 07:46 AM

ok and I fund real issue , it is not div class or # , only the space between the param DESKTOP MODE should be DESKTOP_MODE , and 1 question mark NO ACCOUNT YET? should be NO_ACCOUNT_YET so the fixes are easier

neo 03-24-2011 10:23 AM

OK , fix is up , now , I fund out that this happens only on 5.3.0 -5.3.3 , this was php parse_ini_file() bug and seems fixed from 5.3.3

due to this we cannot say that it is grid bug but the php bug , so we will not change the grid version.

Since we cannot know what php version you will have, we updated all 1.6 templates/demos ,

the fix is very simple ,

open

root/language/ en-GB/en-GB.tpl_TEMPLATE_NAME.ini


change
Code:

NO ACCOUNT YET?
DESKTOP MODE
MOBILE MODE
DESKOT  OFF
MOBILE OFF

to
Code:

NO_ACCOUNT_YET
DESKTOP_MODE
MOBILE_MODE
DESKOTP_OFF
MOBILE_OFF

than go to

root/templates/yourtemplate_name/layous/mobile/

folder


open all 4 files you see and find the text call you previously changed , simply add underscore where you see the empty space

example :
Code:

JText::_('DESKOTP OFF')?>
change to
Code:

JText::_('DESKOTP_OFF')?>


All times are GMT -4. The time now is 07:52 PM.

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.