Youjoomla Support Forums (http://www.youjoomla.com/joomla_support/index.php)
-   YJ Movie Studio Free version (http://www.youjoomla.com/joomla_support/forumdisplay.php?f=97)
-   -   YJStudio (http://www.youjoomla.com/joomla_support/showthread.php?t=6727)

LMICassie 09-02-2010 11:30 AM

YJStudio
 
Adding this module to the SOLUTIONS template and I'm getting the following error: DB function failed with error number 1146
Table 'abcd_dbase.jos_yjstudio' doesn't exist SQL=SELECT * FROM jos_yjstudio where video_status = 1

Not sure where to begin looking for solutions.

jaycburton 09-02-2010 11:45 AM

Hi Cassie - Did the installation succeed successfully? It sounds as if it did not as some database table is missing.

LMICassie 09-02-2010 11:50 AM

Yes, it gave me a successful install message.

jaycburton 09-02-2010 11:55 AM

Okay, great. Have you looked at the database (using phpMyAdmin) to see if there is a table entitled "jos_yjstudio"?

LMICassie 09-02-2010 01:10 PM

Okay, i'm in admin and i do not see a table. do we know how many fields it will require? what name to give the field? type? length/values1? default2? collation? attributes? NULL? Index? auto_increment? ???

jaycburton 09-02-2010 01:12 PM

Here is the SQL to create it:

CREATE TABLE IF NOT EXISTS `jos_yjstudio` (
`id` int(11) NOT NULL auto_increment,
`video_file` varchar(100) NOT NULL,
`video_title` varchar(30) NOT NULL,
`video_desc` varchar(100) NOT NULL,
`video_thumb` varchar(100) NOT NULL,
`video_preview` enum('0','1') NOT NULL default '1',
`preview_width` int(100) NOT NULL,
`preview_height` int(100) NOT NULL,
`added_date` datetime NOT NULL,
`video_status` tinyint(1) NOT NULL,
`ordering` int(11) default NULL,
PRIMARY KEY (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=13 ;

LMICassie 09-02-2010 01:21 PM

Let me giver a try...

Making progress - now I get:
Notice: Undefined offset: 0 in /home/lwma/public_html/modules/mod_yj_studio/mod_yj_studio.php on line 70

Notice: Trying to get property of non-object in /home/lwma/public_html/modules/mod_yj_studio/mod_yj_studio.php on line 70

Notice: Undefined offset: 0 in /home/lwma/public_html/modules/mod_yj_studio/mod_yj_studio.php on line 77

Notice: Trying to get property of non-object in /home/lwma/public_html/modules/mod_yj_studio/mod_yj_studio.php on line 77

Notice: Undefined offset: 0 in /home/lwma/public_html/modules/mod_yj_studio/mod_yj_studio.php on line 77

Notice: Trying to get property of non-object in /home/lwma/public_html/modules/mod_yj_studio/mod_yj_studio.php on line 77

jaycburton 09-02-2010 01:23 PM

HI - LOL Okay. In that case, I would drop that table you just created, download the extension again, and reinstall it. It should install everything needed for the database automatically.


All times are GMT -4. The time now is 07:26 PM.

Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.